Hey Community

The ivy.core team just started to release a BETA version of MacDesigner. How is you user experience with it? Can you work with it on a daily basis? Please share issues or work-arounds that only occur on the MAC platform so that we can improve our work.

alt text

Download:

Outlook:

  • SERVE: build the MAC designer for all our official release (see downloads). 7.3 will be the first official version with a MAC Designer. But currently it comes as beta as we have not much experience with its stability.
  • REACT: we plan to address minor issues and glitches which only occur on MAC OSX.
  • TEST: currently the automated testing process is not as mature as for our other platforms. We will raise our effort in this area once we recognize that the group of Mac Devs grow

Looking for a 7.0 version?

https://answers.axonivy.com/questions/3156/is-there-anyway-to-run-ivy-designer-7-0-on-macos

asked 13.02.2019 at 10:25

Reguel%20Wermelinger's gravatar image

Reguel Werme... ♦♦
9.4k21958
accept rate: 70%

edited 15.02.2019 at 05:10


XATTR Problem

If I download and run the Axon.ivy Designer with Safari on my High Sierra the Designer does not start. The unzipped 'Axon.ivy Designer.app' can not be booted: (fails with an Eclipse window stating that the Engine boot failed -> See /logs

Occasionally a dialog could appear that warn the user about the app verification: Designer is damaged alt text

Cause:

Solution:

  • Remove XATTRS with this command in a terminal: sudo xattr -r -d com.apple.quarantine Axon.ivy Designer.app Afterwards the Designer boots like a charm...

Gray Process Editor

The Designers shows only a grayed out editing window when I open a new process with the Process Editor.

Work-Around:

  • force a re-drawing of your editing content with a Zoom+IN/Zoom+OUT keyboard combination: (Apple+/Apple-)

Designer boots with gray empty front-end

The Designers boots but shows only a gray empty window.

Cause:

  • Java Runtime Environment (JRE) is not compatible. The ivy version 7.3 only runs with a Java 1.8 JRE. Sprint releases of 7.4 should already run with the Java 11 (LTS).

Work-Around:

  • Install a JAVA 11 JRE: e.g. from AdoptopenJDK: https://adoptopenjdk.net/releases.html#x64_mac
  • Finder: Right Click on AxonIvyDesigner > Show Package Contents > Open the file Axon.ivy Designer.app/Contents/Info.plist
  • Define the -VM argument under the <key>Eclipse</key> and point it to compatible Java installation. As it is shown in the out-commented section just below.
  • Verify by rebooting the designer and optionally checking the booted java version in a terminal: ps -e | grep java

alt text

link
This answer is marked "community wiki".

answered 13.02.2019 at 10:44

SupportIvyTeam's gravatar image

SupportIvyTeam ♦♦
1.4k101118122
accept rate: 77%

edited 12.12.2019 at 04:03

Reguel%20Wermelinger's gravatar image

Reguel Werme... ♦♦
9.4k21958

Hi there

My experience has been okay so far. A few remarks:

  • I installed adoptopenjdk11 with home-brew, but it's not working for me, see error below.

When running it from a shell I get an error:

./Axon.ivy\ Designer Error: could not find libjava.dylib Failed to GetJREPath() Unable to create basic Accelerated OpenGL renderer. Core Image is now using the software OpenGL renderer. This will be slow.

I found this to be a bug:https://bugs.openjdk.java.net/browse/JDK-8213362

  • Max java heap size The vmargs settings placed in Axon Designer.ini are not evaluated. Please see below:

    % cat Eclipse/Axon.ivy\ Designer.ini -vm /Library/Java/JavaVirtualMachines/jdk-11.0.6.jdk/Contents/Home/bin/java -startup ../Eclipse/plugins/org.eclipse.equinox.launcher_1.5.500.v20190715-1310.jar --launcher.library ../Eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.1100.v20190907-0426 -nl en -vmargs -Xms5g -Xmx5g -Dosgi.parentClassloader=ext -Dosgi.requiredJavaVersion=11 -da -Dsun.java.command=AxonIvyDesigner --add-modules=ALL-SYSTEM --add-modules=javafx.base,javafx.controls,javafx.graphics,javafx.media,javafx.web --add-exports=javafx.web/com.sun.webkit.dom=ALL-UNNAMED --add-exports=javafx.web/com.sun.javafx.webkit=ALL-UNNAMED -XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -Dosgi.instance.area.default=@% cat Eclipse/Axon.ivy\ Designer.ini -vm /Library/Java/JavaVirtualMachines/jdk-11.0.6.jdk/Contents/Home/bin/java -startup ../Eclipse/plugins/org.eclipse.equinox.launcher_1.5.500.v20190715-1310.jar --launcher.library ../Eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.1100.v20190907-0426 -nl en -vmargs -Xms5g -Xmx5g -Dosgi.parentClassloader=ext -Dosgi.requiredJavaVersion=11 -da -Dsun.java.command=AxonIvyDesigner --add-modules=ALL-SYSTEM --add-modules=javafx.base,javafx.controls,javafx.graphics,javafx.media,javafx.web --add-exports=javafx.web/com.sun.webkit.dom=ALL-UNNAMED --add-exports=javafx.web/com.sun.javafx.webkit=ALL-UNNAMED -XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -Dosgi.instance.area.default=@user.home/ivy-workspace --module-path=../Eclipse/plugins/lib.javafx.mac_11.0.2/lib/user.home/ivy-workspace --module-path=../Eclipse/plugins/lib.javafx.mac_11.0.2/lib/

.

% ps axu | grep java
pwe               4748 130.0 14.4  6990408 1208912   ??  R    11:53PM   0:10.04 /Library/Java/JavaVirtualMachines/jdk-11.0.6.jdk/Contents/Home/bin/java **-Xms1g -Xmx1g** -XX:+UseG1GC -XX:InitiatingHeapOccupancyPercent=75 -Des.networkaddress.cache.ttl=60 -Des.networkaddress.cache.negative.ttl=10 -XX:+AlwaysPreTouch -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -XX:-OmitStackTraceInFastThrow -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Djava.io.tmpdir=/var/folders/30/sk8tvhy52sx6ddnvnn8wwk0c0000gn/T/elasticsearch-15008019142061129486 -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=data -XX:ErrorFile=logs/hs_err_pid%p.log -Djava.locale.providers=COMPAT -Dio.netty.allocator.type=unpooled -XX:MaxDirectMemorySize=536870912 -Des.path.home=/Applications/Axon.ivy Designer.app/Contents/Eclipse/elasticsearch -Des.path.conf=/Applications/Axon.ivy Designer.app/Contents/Eclipse/elasticsearch/config -Des.distribution.flavor=default -Des.distribution.type=zip -Des.bundled_jdk=false -cp /Applications/Axon.ivy Designer.app/Contents/Eclipse/elasticsearch/lib/* org.elasticsearch.bootstrap.Elasticsearch -Ehttp.port=19200 -Ecluster.name=ivy-elasticsearch-6767838646641248996 -Epath.data=/var/folders/30/sk8tvhy52sx6ddnvnn8wwk0c0000gn/T/elasticsearch-data-6427af79-5993-4ba5-94ec-3f4a1f61cb24
pwe               4765   0.0  0.0  4268276    664 s001  S+   11:53PM   0:00.00 grep java

alt text

it never uses more memory than shown above. Building the workspace is taking very long (5-10 minutes).

  • Also can I run more than one instance of Designer?

On windows this can be done by renaming the .exe and .ini files. Designer 1 runs on 8081, Designer 2 on 8082... This would also be essential. I'd love to work with it, but it's too slow for now.

Any help is greatly appreciated.

Many thanks advance and regards, Peter

link

answered 12.04 at 18:40

peterw81's gravatar image

peterw81
(suspended)
accept rate: 0%

edited 15.04 at 07:36

Reguel%20Wermelinger's gravatar image

Reguel Werme... ♦♦
9.4k21958

thanks a lot for pointing on these shortcomings of the current designer.

  • jdk: yes we already run into the same issue when using homebrew and adoptopenjdk. It think it could be possible to use adoptopenjdk if the normal oracle jdk has also been installed. But we have not really tested this setup. As of today you can work with homebrew anyway and install a dated oracle jdk using brew cask install homebrew/cask-versions/java11
  • memory: We're going to reproduce and find alternatives so that memory can be raised. Or at least come up with a better default setting
(14.04 at 05:03) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image
(14.04 at 05:07) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image

hi there, many thanks for your reply. Thanks for pointing out how to install Oracle JDK using home-brew. That's very useful. I'll check out your scripts tonight. As for the memory issue, I was wondering if the java process could be the integrated tomcat, but then again the .ini file is set to 5 min and 5 max gb heap. I'd assume that the Ivy Designer process as shown above would allocate 5g of memory, which it doesn't. It always stays around 2.7g up to 2.9g.

Generally speaking, how is the memory allocated between the physical Designer process and the java process shown in the picture above? Thanks again for your efforts. I'd really love to work with MacOS. As of now I have to use windows, unfortunately.

(14.04 at 07:02) peterw81 peterw81's gravatar image

Hello. I tested the memory issue and realized that you actually should increase -Xms argument value if you want to increase maximum amount of memory used. It also could be that the line where you put your argument isn't somehow working.

The "java" process shown with 1G is actually the process for elasticsearch so you shouldn't worry much about it. Here is some sample configuration that uses more memory. alt text

You can also enable heap status like on the screenshot by going to preferences ->General and Show heap status

link

answered 15.04 at 07:30

ivy-jla's gravatar image

ivy-jla
166119
accept rate: 66%

edited 15.04 at 08:10

hi there, thanks for your reply. Yes, I found the heap status bar already, that's helpful. also thanks for eplaining the java process. I got it to use more memory, thanks. still it's painfully slow. what JDK are you using? oracle (open or commercial), adoptopenjdk, or perhaps any other?

I am using virtualisation (VMware Fusion), has anyone some recommendations for resources to allocate to VMware (and settings)?

are there any smart vmargs recommended? perhaps another garbage collector or server vm option?

any advice to speed things up little are very welcome.

link

answered 15.04 at 10:40

peterw81's gravatar image

peterw81
(suspended)
accept rate: 0%

edited 15.04 at 12:08

Mhh actually we started building a Mac Designer mainly to let users free from the bondage to use a hypervisor just to develop with the Designer. In essence to have the best user experience (let the user decide on his favorit tooling). In addition, having maximum resource available was also a driver.

Now, it seems like you are using a virtualized Mac OS. I assume that performance restrictions are caused by the hypervisor so general hypervisor rules for mac should apply: share at least 2 cpu cores, allow 3d acceleration, give 128 MB graphic memory, use a virtual drive on an ssd.

(16.04 at 03:28) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image

hi there, thanks again for your reply. I understand your point, I am considering not using virtualisation. currently my vm has 1024mb graphic memory, allows 3d acceleration, uses openGL rendering rather then metal (since I read in VMware forums that those two don't go well together), 3 CPU cores and 10GB memory. I cleared out lots of unnecessary apps and services and tried to slim it down. also I have a rather new ssd (2018).

Thanks again very much for all your support and thoughts.

link

answered 16.04 at 03:56

peterw81's gravatar image

peterw81
(suspended)
accept rate: 0%

edited 16.04 at 04:00

I have now installed everything on the host OS and I am excited, it's brilliant! really fast, memory settings are working as expected, more instances of Designer on problem at all. Thanks for your help and thoughts!!

link

answered 16.04 at 05:22

peterw81's gravatar image

peterw81
(suspended)
accept rate: 0%

having started to work with it now there are two details that I observed:

  • shortcuts for opening resources and types

(on windows CTRL-SHIFT-T and CTRL-SHIFT-R) are not working when the focus is in a process map. the shortcut only works when the focus is in the process explorer (COMMAND instead of CTRL of course). also at times no shortcuts at all work (e.g. undo !, then all that works is selected from the menu, which is annoying)

  • default for zoom

also the I didn't find a way to set a default for the zoom on a process map, which means I always have to zoom twice when opening any sort of process.

  • code tab

sometimes the code tab (or output tab) is shown without text, see image below:

alt text

  • logging

unfortunately I can't find the designer logs. I checked the log4j config file located in ../Contents/Eclipse/configuration/log4jconfig.xml

alt text

user.dir=/Applications/Axon.ivy Designer.app/Contents/MacOS

but there is no log. I double the write permissions on the directory, which should be okay. Also I tried to place a fixed path to the log directory. no luck. how is anyone else getting on with the logging? console (runtime) log is hence also not working.

link

answered 16.04 at 08:38

peterw81's gravatar image

peterw81
(suspended)
accept rate: 0%

edited 16.04 at 10:14

  • logging: known issue unfortunately not yet prioritized to be fixed in the next sprint. Internal this bug is known as: XIVY-3526 Fix Runtimelog for Mac Designer
  • zoom: in process can not be pre-defined. Yet it is dynamic: calculated relative to the text editor font. So if you play with the font in Preferences > General > Appearance > Colors and Fonts > Basic > Text Font you should be able to change the font size ... and therefore also the process editor zoom on next re-open. (may requires a restart)
(16.04 at 10:14) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image
  • shortcuts: are a known issue with the process editor, not only on mac. our long term plan is to rebuild a sexy process editor - so we do not want to investigate.
  • code tab: also saw this from time to time. usually resizing the window helps. but we are working on a proper ui testing environment for mac - so that we can address these issues seriously and discover broken ui parts automatically. But this will take some time since this is not our topmost priority.
(16.04 at 10:15) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image

thanks very much reguel for this infos. what is your gut-feeling about when this runtime log issue will be resolved. shortcuts, zoom and all the other stuff I could live with, but no runtime log is a huge problem. showstopper if you will, which means back to windows .-(

(16.04 at 10:18) peterw81 peterw81's gravatar image

I agree that this is really a big issue. So I'll enforce it to be done by the third-level support - so that at least a hotfix can be provided to make it work. An 8.0.5 with the final fix is currently planned to be released in a month.

(17.04 at 09:22) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image

That'd be much appreciated, thanks very much for your efforts and continuous help!

(17.04 at 12:29) peterw81 peterw81's gravatar image

You are welcome @peterw81 We just published a work-around for the logging issue here: https://answers.axonivy.com/questions/4418/where-to-find-engine-logs-using-the-mac-designer Please verify that it work for you and leave a comment either way on your experience.

(20.04 at 03:30) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image

hi there again. thanks for the workaround. yes, I now can see the eclipse/logs/ivy.log being written to. Also adding a ivy.log.setLevel(Level.ALL); helps seeing the runtime log.

I changed the log4jconfig.xml <root> <level value="ALL"/> <appender-ref ref="FileLog"/> <appender-ref ref="ConsoleAppender"/> </root>

Now I get runtime log entries as expected.

(20.04 at 04:47) peterw81 peterw81's gravatar image

Thanks for testing @peterw81

Meanwhile we have are stabilizing a real fix for 8.0.5 so in about four weeks these log issues will be gone without manual hacking. From then on I'd recommend to remove the ~/xpertivy/log4jconfig.xml and stick to the standard impl.

(20.04 at 10:47) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image

brilliant, thanks for the good news.

(20.04 at 11:00) peterw81 peterw81's gravatar image
showing 5 of 9 show 4 more comments

hi there here are some more observations I made:

  • Process Designer stays grey sometimes when opening a process or subprocess the windows just stays grey. see image below: alt text

  • can't inscribe to some process elements sometimes I just can't open the inscribe dialog window, only after restart of designer it works again.

  • preferences window doesn't show all list elements, resizing the window helps. alt text
  • size of process elements in regards to the zoom and size of the process elements: I changed all font sizes to at least 13, but still the process elements are really small. this didn't seem to make any difference. it doesn't seem to be relative to the font size.

these are not so important issues, yet they can be annoying. perhaps at some point they could be addressed.

link

answered 21.04 at 09:39

peterw81's gravatar image

peterw81
(suspended)
accept rate: 0%

edited 21.04 at 09:43

  • grey editor : see first post ... zooming in and out should help
  • can't inscribe : if you are in this state, can you still open inscription with the 'outline view'? by double clicking on elements? do you see any errors in the 'error log' or logs in the /logs/ivy.log file related to that problem?
  • element size : just tested and I agree that the scaling isn't matching the expectations and also that setting the 'Dialog Font' size doesn't make any difference > opened an issue internally known as XIVY-3956 Process Editor default zoom way too small on MAC
(21.04 at 11:11) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image

Hi Reguel Thanks very much! Apparently when you remove the following line from the Axon.Ivy Designer.ini -Dorg.eclipse.swt.internal.carbon.smallFonts at least the project explorer font size get's bigger. The only one I was not able to set via preferences. Still the process designer is very small, so the issue remains even having removed the above line. in regards to inscribe: I'll let you know, when I run into that issue again. I didn't yet today, but I did quite regularly restart Designer today.

(22.04 at 11:32) peterw81 peterw81's gravatar image

speaking of the devil "not being able to inscribe", it happened. No, also in the outline view, I am not able to open the inscribe dialog. no log entries...

(22.04 at 11:54) peterw81 peterw81's gravatar image

Hi there again another observation is that simulating a process (even in fastest setting) is quite lame. this takes unnecessary time. perhaps the speed of the simulation can be raised?

another point: sometimes, I have the feeling, after you abort a running process by hitting the red stop button in the top bar, the designer engine is gone. in my browser window I get a site can't be reached, connection refused. again, restart is the only thing that helps.

many thanks, p

(22.04 at 14:47) peterw81 peterw81's gravatar image
  • animation speed can you record a video of it? I only have a MacMini to test and I access it via VNC ... so animation is always kind of slow (but I always blamed the remote desktop for it).

(23.04 at 04:03) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image
  • inscribe can you confirm that you looked into the 'error log' view and /logs/ivy.log file and no evidence is available why the process is blocked from adding inscriptions? I do have a lot of false positives in the error log ... but never no errors. So I think there must be an evidence for the freeze. It's almost impossible without any logs to tackle the issue as I can't reproduce it here. Does it may only happen after some specific element has been inscribed?
(23.04 at 04:11) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image
  • browser can you test whether your real browser (not in the designer) could still access the embedded engine when it is blocked in the Designer?
(23.04 at 04:12) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image

Hi @peterw81

I hope you are still valiantly working with the Mac Designer.app. Thanks to your effort we have a bunch of issues solved on 8.0.5. 😍

However the 'Browser' and 'Inscribe' bug still bothers us. For the browser we have meanwhile other customers facing similar issues on different platforms - maybe they can provide data on the cause. But for both bugs recording 'thread dumps' could be the solution. Very likely an EVENT thread (e.g. AWT) is blocked. Can you record a thread dump using visualvm when you face one of the issues next time? https://visualvm.github.io/

(30.04 at 02:41) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image

You can create Thread Dumps most conveniently using VisualVM. Install and open it:

  • select the JavaVM to analyze (Designer)
  • go to the 'Threads' tab
  • hit the 'Thread dump' button (repeat this 3 times ... with a few seconds pause in between)
  • share the created .tdump files with us: we may can see a locking issue in it.

(30.04 at 02:45) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image

Hi there,

I'll see what I can do about the thread dump and video for the simulation speed. Frankly, there is another issue that is really frustrating me. Intermittently "Jump to referenced process" is crashing Designer. This is really really bad, since I use it very frequently. Again, it keeps just hanging and no log entries. All there is left to do is killing the OS process and restarting it (which is again a time-consuming matter)

(04.05 at 12:28) peterw81 peterw81's gravatar image

As for the browser: it's not the internal browser that can't connect, it's my external Chrome that can't open the site anymore. I don't use the internal browser at all. Also sometimes values set in an inscribe dialog are not being saved. This means I always have to double check if it stored my code and/or values. This takes a lot of time, since Designer is generally speaking not very responsive. Frustration levels rise when you push a button and it takes several moments (seconds) until something happens.

I hear from windows users issues along the same lines.

(04.05 at 12:28) peterw81 peterw81's gravatar image

Thanks a lot @peterw81 The hint with using the 'jumping to referenced process' action was very helpful. I could reproduce this when using the menu on a process activity and reported the issue: XIVY-4055 AWT Thread blocked when jumping to referenced process on Mac Since the recorded stack exposes a very generic locking issue when dealing with Fonts in the ProcessEditor stack I could imagine that also other 'freeze' scenarios come back to the same issue. So we will definitively have a look at this. One note; I faced the issue less when using key action (press J when hovering an activity)

(05.05 at 05:36) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image

Hi there, many thanks for the hint with pressing J, i'll try to do that and keep you posted. Glad you can now reproduce the issue! Hopefully this can be fixed soon-isch.

(05.05 at 05:44) peterw81 peterw81's gravatar image

Hey @peterw81 We've just fixed the 'thread blocking' issue that arose when using the menu 'jump to referenced process'.

If you want to play with the improved designer you can get it here: https://dev.axonivy.com/permalink/nightly/axonivy-designer-macosx-beta.zip But be aware that this is the leading edge version - already containing 9.1 features which may not comply with 8.0. It would be interesting for us if there are any blocking issues left....

At any rate, 8.0.5 can be expected in a few days and will also contain the fix :-)

(07.05 at 03:05) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image

sorry, didn't have time to play. also, if it's not 8.0 compliant, then the risk is too high for me to use it. I'd rather wait for 8.0.5.

(07.05 at 13:03) peterw81 peterw81's gravatar image

good new for Apple users: Axon.ivy Designer.app 8.0.5 is available https://dev.axonivy.com/download

Enjoy @peterw81

(08.05 at 05:04) Reguel Werme... ♦♦ Reguel%20Wermelinger's gravatar image
showing 5 of 16 show 11 more comments

hi there

Thanks 8.0.5 is pretty stable and a huge improvement. There is one little thing I really miss a lot: when editing a data class, pressing tab would also go focus on the open select datatype dialog. Now it leaves the little C-Icon out. When I press tab takes the focus out of the line. alt text It would be very very convenient if I could press tab to focus on the open dialog and then by pressing space the dialog opens. Then I would not need to use the pointer to open the dialog.

link

answered 12.05 at 08:33

peterw81's gravatar image

peterw81
(suspended)
accept rate: 0%

also, sometimes when selecting a data class in the dialog, it's not correctly set in the dataclass definition. repeating the procedure (opening the dialog by using the pointer and press the C-Icon, searching and selecting the desired type by double-clicking it) helps. I hear from windows users, that they have the same issues.

(12.05 at 09:40) peterw81 peterw81's gravatar image
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×78
×3
×1
×1

Asked: 13.02.2019 at 10:25

Seen: 1,819 times

Last updated: 12.05 at 09:40