The Axis Version (1.4 1156 May 23 2006) currently used in ivy still contains the following bug: https://issues.apache.org/jira/browse/AXIS2-4468 which is fixed with Axis 1.6

In some environments this leads to problems. Is there an easy workaround and when do you plan to upgrade to a newer Axis release?

Thanks a lot

asked 27.10.2014 at 13:30

Wolfgang%20Heil's gravatar image

Wolfgang Heil
11112
accept rate: 0%


Axis2 lib upgrade: AFAIK upgrade of Axis2 is not planned, because newer Axis2 versions generate incompatible WS Stub Java files. It means all WS clients should be regenerated, and many parameter assignments should be also re-created by users.

Workaround: As i see the comment from "Michael Fryars" (19/Aug/09 08:36) the problem does not occur (at least with ISO) when ADB is used. Axon.ivy uses ADB. On the other hand i suggest to use the same encoding for the Request and for the Reponse. This issue seems to talk about different request / response encoding.

link

answered 03.11.2014 at 08:51

Tamas%20KIS's gravatar image

Tamas KIS
456238
accept rate: 60%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×5

Asked: 27.10.2014 at 13:30

Seen: 2,942 times

Last updated: 03.11.2014 at 08:51